FieldPro app works on all mobile phones with at least Android 7, which is less than 2 years old.

Click here to see the minimum requirements in full.